Typedb have problem or not active

Can help me, pls

Hi there - what OS and Architecture are you on?


I use Kali Linux version 2023.4, i cant use “typedb console”, help me pls, thanks

Hello my friend, i thought i solved my problem but now i have a new problem. I cannot perform the same operation as operation 3 in the typedb-console installation instructions, because I have previously installed typedb core and was also instructed to link to the address usr/local/bin/typedb. currently i can’t link typedb-console to /usr/local/bin/typedb. So how to fix the error? Thank you my friend.

Since you’ve symlinked /usr/local/bin/typedb to a typedb-all distribution, you don’t need to have a separate typed-console distribution.

What error do you get when you run typedb console now ?

so how do i use typedb-console? I typed the command “typedb console” and only one line of messages like the picture appears. thanks my friend

Can you try unset _JAVA_OPTIONS and see whether the message changes?

how to changes? i dont know :frowning: thanks mmy friend

I tried it and it doesn’t seem right

hello my friend, in the beginning i just installed typedb-core but i couldn’t use typedb console, so i tried downloading and installing typedb console. Or maybe I used the typedb console in the wrong syntax, can you help me use the typedb console? Thank you very much my friends

You can try running this, since you seem to have it in /opt/typedb-console
/opt/typedb-console/typedb-console-linux-x86_64-2.26.6/typedb console

Alternately, Download it and extract it from : curl -1sLf -O 'https://repo.typedb.com/public/public-release/raw/names/typedb-console-linux-x86_64/versions/latest/typedb-console-linux-x86_64-2.26.6.tar.gz'

Meanwhile, We’ll try to get a similar version of linux to see if we can replicate it.

I tried but it doesn’t seem to work

I’ve managed to reproduce your crash. This has been fixed in master and will be released in the next few days.
Here’s a snapshot if you want to unblock yourself:
curl -1sLf -O 'https://repo.typedb.com/public/public-snapshot/raw/names/typedb-console-linux-x86_64/versions/90ce30f203f8af94d37e03d909a76295e3a132fa/typedb-console-linux-x86_64-90ce30f203f8af94d37e03d909a76295e3a132fa.tar.gz'

Remember to use ./typedb console so it doesn’t run the one in /opt

thank you so much, now i can use typedb consele . thanks for help me :star_struck: